http://www.gupiaott.com

通达信超准趋势主图指标公式源码详解

本文标题:通达信超准趋势主图指标公式源码详解
内容由 股票头条小编 整理编辑,关键词是趋势,详解,指标,公式,源码,摘要 顶线:(1+6/100)*MA(CLOSE,25),COLORLIGRAY;底线:(1-6/100)*MA(CLOSE,25),COLORLIGRAY;趋势线:(顶线+底线)/2;IF(趋势线<=RE ....具体详情请阅读下文。

通达信超准趋势主图指标公式源码详解

顶线:(1+6/100)*MA(CLOSE,25),COLORLIGRAY;

底线:(1-6/100)*MA(CLOSE,25),COLORLIGRAY;

趋势线:(顶线+底线)/2;

IF(趋势线<=REF(趋势线,1),趋势线,DRAWNULL),COLORGREEN;

IF(趋势线>=REF(趋势线,1),趋势线,DRAWNULL),COLORMAGENTA;

VAR1:=REF(CLOSE,1);

VAR2:=SMA(MAX(CLOSE-VAR1,0),6,1)/SMA(ABS(CLOSE-VAR1),6,1)*100;

STICKLINE(CROSS(84,VAR2),CLOSE,OPEN,2.8,0),COLORGREEN;

VAR3:=CROSS(84,VAR2);

DRAWTEXT(VAR3,HIGH*1.001,2),COLORGREEN;

VAR4:=DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1);

DRAWTEXT(FILTER(BBI>REF(BBI,1) AND CLOSE>VAR4,10),LOW*0.998,4),COLORLIRED;

DRAWTEXT_FIX(ISLASTBAR,0,0,0,CODE),COLORGREEN;

DRAWTEXT_FIX(ISLASTBAR,0.1,0,0,STKNAME),COLORMAGENTA;

DRAWTEXT_FIX(ISLASTBAR,0.2,0,0,HYBLOCK),COLORCYAN;

DRAWTEXT_FIX(ISLASTBAR,0.3,0,0,DYBLOCK),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.4,0,0,GNBLOCK),COLORGREEN;

DRAWTEXT_FIX(ISLASTBAR,0.02,1,0,FGBLOCK),COLORWHITE;

DRAWTEXT_FIX(1,0,0.05,0,STRCAT(9,EXTERNSTR(0,1))),COLORDB11E5;

DRAWTEXT_FIX(1,0,0.1,0,STRCAT(10,EXTERNSTR(0,2))),COLORGREEN;

DRAWTEXT_FIX(1,0,0.15,0,STRCAT(11,EXTERNSTR(0,4))),COLORRED;

VAR5:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

VAR6:=SMA(VAR5,3,1);

VAR7:=SMA(VAR6,3,1);

VAR8:=(VAR6+VAR7)/2;

VAR9:=VAR8>REF(VAR8,1) AND REF(VAR8,1)<REF(VAR8,2);

VAR10:=VAR8<REF(VAR8,1) AND REF(VAR8,1)>REF(VAR8,2);

VAR11:=EMA(CLOSE,2);{wwwgoodgupiaocom}

生命线:EMA(SLOPE(CLOSE,9)*20+CLOSE,37);

IF(生命线<=REF(生命线,1),生命线,DRAWNULL),COLORGREEN,LINETHICK2;

IF(生命线>=REF(生命线,1),生命线,DRAWNULL),COLORRED,LINETHICK2;

升度:生命线/REF(生命线,1)*1000,NODRAW,COLORLIRED;

降度:REF(生命线,1)/生命线*1000,NODRAW;

VAR12:=COUNT(REF(EMA(CLOSE,3),1)<REF(EMA(CLOSE,3),2),5)=5 AND EMA(CLOSE,3)>REF(EMA(CLOSE,3),1);

DRAWICON(VAR12,LOW*0.995,25);

VAR13:=LLV(DMA(CLOSE,VOL/CAPITAL),120);

VAR14:=200*(CLOSE-VAR13)/VAR13;

VAR15:=CROSS(VAR14,15);

VAR16:=BARSLASTCOUNT(VAR14<15)>25;

DRAWTEXT(VAR15 AND REF(VAR16,1),LOW*0.98,14),COLORYELLOW;



推荐阅读:

以上就是小编为您带来的“通达信超准趋势主图指标公式源码详解”全部内容,更多内容敬请关注股票头条!

郑重声明:股票头条整理的配资相关新闻只为转载网络,目的是传递更多信息,并不意味着赞同其观点,不构成投资建议。